const regex = new RegExp('<(a|h1|p|title)[^>]*>([^<]+)</\\1[^>]*>', 'g')
const str = `<h1> content goeas here </h1>
<a href="foo.html">lmskdfg</a>
<title>qsdfqsdf</title>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}