re = /<(a|h1|p|title)[^>]*>([^<]+)<\/\1[^>]*>/
str = '<h1> content goeas here </h1>
<a href="foo.html">lmskdfg</a>
<title>qsdfqsdf</title>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end