const regex = /(?:\d{2,3}?(:IF))?[\s,&]+(with)?|(\\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\d{2,3}?(:IF))?[\\s,&]+(with)?|(\\\\S+)', 'gm')
const str = `01:IF rd.h && dq.L && o.LL && v.L THEN la.VHB , av.VHR with 0.4610;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);