import Foundation
let pattern = #"(?:\d{2,3}?(:IF))?[\s,&]+(with)?|(\\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"01:IF rd.h && dq.L && o.LL && v.L THEN la.VHB , av.VHR with 0.4610;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)