use strict;
my $str = '01:IF rd.h && dq.L && o.LL && v.L THEN la.VHB , av.VHR with 0.4610;';
my $regex = qr/(?:\d{2,3}?(:IF))?[\s,&]+(with)?|(\\S+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";