using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\|(.*?)\|.*$";
string input = @" --- blablabla N° : 0533333333 | XXXXX XXXX XXX | 24/12/2016 | - blabla ,";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}