$re = '/^.*?\|(.*?)\|.*$/';
$str = ' --- blablabla N° : 0533333333 | XXXXX XXXX XXX | 24/12/2016 | - blabla ,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);