package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*?\|(.*?)\|.*$`)
var str = ` --- blablabla N° : 0533333333 | XXXXX XXXX XXX | 24/12/2016 | - blabla ,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}