package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z]+=\"[^\"]*?\")`)
var str = `<lolz>
<>
<meh crap="shit">
<bullshit turds="dick" crap="lolz" meh="turds">
random
random
</bullshit>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}