import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z]+=\\\"[^\\\"]*?\\\")";
final String string = "<lolz>\n"
+ "<>\n"
+ "<meh crap=\"shit\">\n"
+ "<bullshit turds=\"dick\" crap=\"lolz\" meh=\"turds\">\n"
+ " random\n"
+ " random\n"
+ " </bullshit>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}