package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[ \d\p\wa-zA-Z0-9 ]{3,25}$`)
var str = ` محمد125 hasan`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}