$re = '/^[ \d\p\wa-zA-Z0-9 ]{3,25}$/u';
$str = ' محمد125 hasan';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);