const regex = new RegExp('^[ \\d\\p\\wa-zA-Z0-9 ]{3,25}$', 'u')
const str = ` محمد125 hasan`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}