package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^From:.*\n.*(John).*`)
var str = `From: Test, Jane Sent: Friday, August 28, 2015 12:51 PM To: Test, Joe Cc: Test, Bill; Doe, John Subject: Report
John please mark this report as finished.
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}