$re = '/^From:.*\n.*(John).*/s';
$str = 'From: Test, Jane Sent: Friday, August 28, 2015 12:51 PM To: Test, Joe Cc: Test, Bill; Doe, John Subject: Report
John please mark this report as finished.
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);