re = /^From:.*\n.*(John).*/
str = 'From: Test, Jane Sent: Friday, August 28, 2015 12:51 PM To: Test, Joe Cc: Test, Bill; Doe, John Subject: Report
John please mark this report as finished.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end