using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(/\*.+?(?<!\*/)special.+?(?:\*/)+?)";
string input = @"/*
sd sdf sdf
*
* sdf sdf fasdfga
* dsf sd sdf sdf sdf
*/
special
*/
/*
sd sdf sdf
*
special
* sdf sdf fasdfga
* dsf sd sdf sdf sdf
*/
special
*/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}