$re = '/(?s)(/\*.+?(?<!\*/)special.+?(?:\*/)+?)/m';
$str = '/*
sd sdf sdf
*
* sdf sdf fasdfga
* dsf sd sdf sdf sdf
*/
special
*/
/*
sd sdf sdf
*
special
* sdf sdf fasdfga
* dsf sd sdf sdf sdf
*/
special
*/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);