import re
regex = re.compile(r"(?s)(/\*.+?(?<!\*/)special.+?(?:\*/)+?)", flags=re.MULTILINE)
test_str = ("/*\n"
" sd sdf sdf\n"
" * \n\n"
" * sdf sdf fasdfga \n"
" * dsf sd sdf sdf sdf\n\n"
" */\n\n"
"special\n\n"
"*/\n\n\n\n"
"/*\n"
" sd sdf sdf\n"
" * \n"
" special\n"
" * sdf sdf fasdfga \n"
" * dsf sd sdf sdf sdf\n\n"
" */\n\n"
"special\n\n"
"*/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")