#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x)#" & @CRLF & _
"# DocBlock to PHPDoc" & @CRLF & _
"#" & @CRLF & _
"# @author Richard Fussenegger <richard@fussenegger.info>" & @CRLF & _
"#" & @CRLF & _
"# Original phpDocumentor RegExp" & @CRLF & _
"#[ \t]*(?:\/\*\*|\*\/|\*)?[ \t]{0,1}(.*)?" & @CRLF & _
"#" & @CRLF & _
"(?:^\s*\/\*\*\s+(?:\*[ \t]?)?|\s+\*\/\s*|[ \t]+\*[ \t]?)" & @CRLF & _
""
Local $sString = "/**" & @CRLF & _
" * This is a summary." & @CRLF & _
" * This is a {@internal beautiful}} description." & @CRLF & _
" *" & @CRLF & _
" * @see \SimpleXmlElement the XML reader with which this object is constructed" & @CRLF & _
" * @var \SimpleXmlElement {" & @CRLF & _
" * The configuration root node that contains all settings for this component." & @CRLF & _
" * @property string \$name" & @CRLF & _
" * @property integer \$version" & @CRLF & _
" * }" & @CRLF & _
" */"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)