import Foundation
let pattern = ##"""
#
# DocBlock to PHPDoc
#
# @author Richard Fussenegger <richard@fussenegger.info>
#
# Original phpDocumentor RegExp
#[ \t]*(?:\/\*\*|\*\/|\*)?[ \t]{0,1}(.*)?
#
(?:^\s*\/\*\*\s+(?:\*[ \t]?)?|\s+\*\/\s*|[ \t]+\*[ \t]?)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
/**
* This is a summary.
* This is a {@internal beautiful}} description.
*
* @see \SimpleXmlElement the XML reader with which this object is constructed
* @var \SimpleXmlElement {
* The configuration root node that contains all settings for this component.
* @property string \$name
* @property integer \$version
* }
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)