using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[.*?(\(a\*, b\*\) .*?)\]\]";
string input = @"[[(a*, b*) within 20]] or [[...(a*, b*) within 20]]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}