re = /\[\[.*?(\(a\*, b\*\) .*?)\]\]/
str = '[[(a*, b*) within 20]] or [[...(a*, b*) within 20]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end