$re = '/\[\[.*?(\(a\*, b\*\) .*?)\]\]/';
$str = '[[(a*, b*) within 20]] or [[...(a*, b*) within 20]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);