using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?<!NEWDIR)\/MYDIR\/filename\.aspx$";
string input = @"http://anydomain/MYDIR/filename.aspx
http://anydomain/NEWDIR/MYDIR/filename.aspx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}