$re = '/^.*(?<!NEWDIR)\/MYDIR\/filename\.aspx$/m';
$str = 'http://anydomain/MYDIR/filename.aspx
http://anydomain/NEWDIR/MYDIR/filename.aspx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);