re = /^.*(?<!NEWDIR)\/MYDIR\/filename\.aspx$/m
str = 'http://anydomain/MYDIR/filename.aspx
http://anydomain/NEWDIR/MYDIR/filename.aspx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end