use strict;
my $str = '154787878_2582_test.txt.zip';
my $regex = qr/(?:\d+)_(.*)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";