import re
regex = re.compile(r"(?:\d+)_(.*)", flags=re.MULTILINE)
test_str = "154787878_2582_test.txt.zip"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)