$re = '/(?:\d+)_(.*)/m';
$str = '154787878_2582_test.txt.zip';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;