import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(?= = CreateObject)|(?<=MoveObject\\()[^,]+";
final String string = "Word = CreateObject(980, -1696.5996, -12.2998, 5.3, 0, 0, 317.999);\n\n"
+ "MoveObject(Word, -1660.9004, 79.40039, 2.2,6);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}