re = /.*?(?= = CreateObject)|(?<=MoveObject\()[^,]+/m
str = 'Word = CreateObject(980, -1696.5996, -12.2998, 5.3, 0, 0, 317.999);
MoveObject(Word, -1660.9004, 79.40039, 2.2,6);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end