const regex = /.*?(?= = CreateObject)|(?<=MoveObject\()[^,]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(?= = CreateObject)|(?<=MoveObject\\()[^,]+', 'gm')
const str = `Word = CreateObject(980, -1696.5996, -12.2998, 5.3, 0, 0, 317.999);
MoveObject(Word, -1660.9004, 79.40039, 2.2,6);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}