using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<()(?R){2}>\z|\1\Q^<()(?R){2}>\z|\1\Q";
string input = @"<^<()(?R){2}>\z|\1\Q^<()(?R){2}>\z|\1\Q>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}