const regex = /^\/()(?R){2}\/\z|\1\Q^\/()(?R){2}\/\z|\1\Q/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/()(?R){2}\\\/\\z|\\1\\Q^\\\/()(?R){2}\\\/\\z|\\1\\Q', '')
const str = `/^\\/()(?R){2}\\/\\z|\\1\\Q^\\/()(?R){2}\\/\\z|\\1\\Q/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}