$re = '/^\/()(?R){2}\/\z|\1\Q^\/()(?R){2}\/\z|\1\Q/';
$str = '/^\\/()(?R){2}\\/\\z|\\1\\Q^\\/()(?R){2}\\/\\z|\\1\\Q/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);