re = /^\/()(?R){2}\/\z|\1\Q^\/()(?R){2}\/\z|\1\Q/
str = '/^\\/()(?R){2}\\/\\z|\\1\\Q^\\/()(?R){2}\\/\\z|\\1\\Q/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end