#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\t)(?:\d+|KY\d+|([^\t]+))(?=\t|$)"
Local $sString = "1025164 HERBEX IBERIA, S.L.U. KY01 4600292091" & @CRLF & _
"1016379 DRISCOLL´S OF EUROPE B.V. KY01 4600322589" & @CRLF & _
"1008809 KY01 LANDGARD NORD OBST & GEMÜSE GM 4600347315" & @CRLF & _
"1008835 C.A.S.I. : COOPERATIVA PROVINC KY01 4600348112" & @CRLF & _
"1019258 SYDGRÖNT EKONOMISK FÖRENING KY02 460034342" & @CRLF & _
"1019258 3 M SVENSKA AB KY02 460034342" & @CRLF & _
"1019258 460034342 3 M SVENSKA AB KY02" & @CRLF & _
"3 M SVENSKA AB KY02 460034342 1019258" & @CRLF & _
"1019258 460034342 KY02 3 M SVENSKA AB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")