using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\t)(?:\d+|KY\d+|([^\t]+))(?=\t|$)";
string input = @"1025164 HERBEX IBERIA, S.L.U. KY01 4600292091
1016379 DRISCOLL´S OF EUROPE B.V. KY01 4600322589
1008809 KY01 LANDGARD NORD OBST & GEMÜSE GM 4600347315
1008835 C.A.S.I. : COOPERATIVA PROVINC KY01 4600348112
1019258 SYDGRÖNT EKONOMISK FÖRENING KY02 460034342
1019258 3 M SVENSKA AB KY02 460034342
1019258 460034342 3 M SVENSKA AB KY02
3 M SVENSKA AB KY02 460034342 1019258
1019258 460034342 KY02 3 M SVENSKA AB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}