use strict;
my $str = '1025164 HERBEX IBERIA, S.L.U. KY01 4600292091
1016379 DRISCOLL´S OF EUROPE B.V. KY01 4600322589
1008809 KY01 LANDGARD NORD OBST & GEMÜSE GM 4600347315
1008835 C.A.S.I. : COOPERATIVA PROVINC KY01 4600348112
1019258 SYDGRÖNT EKONOMISK FÖRENING KY02 460034342
1019258 3 M SVENSKA AB KY02 460034342
1019258 460034342 3 M SVENSKA AB KY02
3 M SVENSKA AB KY02 460034342 1019258
1019258 460034342 KY02 3 M SVENSKA AB';
my $regex = qr/(?:^|\t)(?:\d+|KY\d+|([^\t]+))(?=\t|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}