using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(FunFehlerButton: Execute).*";
string substitution = @"$1";
string input = @"INFO: Device 6: Time 20.11.2015 06:28:00 - [Script] FunFehlerButton: Execute [0031 text]
INFO: Device 0: Time 09.12.2015 03:51:44 - [Replication] FunFehlerButton: Execute
INFO: Device 6: Time 20.11.2015 06:28:00 - FunFehlerButton: Execute";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}