$re = '/.*(FunFehlerButton: Execute).*/';
$str = 'INFO: Device 6: Time 20.11.2015 06:28:00 - [Script] FunFehlerButton: Execute [0031 text]
INFO: Device 0: Time 09.12.2015 03:51:44 - [Replication] FunFehlerButton: Execute
INFO: Device 6: Time 20.11.2015 06:28:00 - FunFehlerButton: Execute';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;