import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(FunFehlerButton: Execute).*";
final String string = "INFO: Device 6: Time 20.11.2015 06:28:00 - [Script] FunFehlerButton: Execute [0031 text] \n"
+ "INFO: Device 0: Time 09.12.2015 03:51:44 - [Replication] FunFehlerButton: Execute \n"
+ "INFO: Device 6: Time 20.11.2015 06:28:00 - FunFehlerButton: Execute";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}