#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(N|S)?\s*(\d*[.])?\d+(\x{00b0}\s*)?((\d*[.])?\d+((\x{0022})|((\x{0027}\s*)?)?((\d*[.])?\d+?(\x{0022})?)?))?[\s\x{002c}]+(W|E)?\s*(\d*[.])?\d+(\x{00b0}\s*)?((\d*[.])?\d+((\x{0022})|((\x{0027}\s*)?)?((\d*[.])?\d+(\x{0022})?)?))?$"
Local $sString = "n 1 e 0" & @CRLF & _
"n 1.1 e 0" & @CRLF & _
"n49.54.15.21 e1" & @CRLF & _
"n49.54.15.21° e1" & @CRLF & _
"n49.54.15.21' e1" & @CRLF & _
"n49.54.15.21" e1" & @CRLF & _
"n49.54' 15.24" e1" & @CRLF & _
"n49.54' 15.24.541" e1" & @CRLF & _
"n49.54.15.21' 5456.4646" e1" & @CRLF & _
"n 1° e 0" & @CRLF & _
"n 1.1° e 0" & @CRLF & _
"n 1.1.1° e 0" & @CRLF & _
"n 1°1 e 0" & @CRLF & _
"n 1.1°1 e 0" & @CRLF & _
"n 1°1' e 0" & @CRLF & _
"n 1.1°1' e 0" & @CRLF & _
"n 1.1°1.1 e 0" & @CRLF & _
"n 1.1°1.1' e 0" & @CRLF & _
"n 1°1.1.1 e 0" & @CRLF & _
"n 1.1°1.1.1 e 0" & @CRLF & _
"n 1°1.1.1' e 0" & @CRLF & _
"n 1.1°1.1.1' e 0" & @CRLF & _
"n 1.1°12.12.12 e 0" & @CRLF & _
"n 1.1°12.12.12' e 0" & @CRLF & _
"n 1°1" e 0" & @CRLF & _
"n 1.1°1" e 0" & @CRLF & _
"n 1°1.12.21" e 0" & @CRLF & _
"n 11.11°12.212.21" e 0" & @CRLF & _
"n 11.11°11.1111'12212.21" e 0" & @CRLF & _
"n 11.11°11.11.11'12212.21" e 0" & @CRLF & _
"n 11.11°11.1111'12.212.21" e 0" & @CRLF & _
"N 0° 00' 000.000" E 0° 00' 000"" & @CRLF & _
"N0°00'000 E0°00'" & @CRLF & _
"n 0° 00 , w 0° 00.000" & @CRLF & _
"S 0° 0" ,E 0° 0.00"" & @CRLF & _
"s 0.00°, w0" & @CRLF & _
"N 49°121.47.247",W16°5496.2944466.54"" & @CRLF & _
"N 49°12.41.47247",W16°54.96'4.2946654""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")