# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(N|S)?\s*(\d*[.])?\d+(\x{00b0}\s*)?((\d*[.])?\d+((\x{0022})|((\x{0027}\s*)?)?((\d*[.])?\d+?(\x{0022})?)?))?[\s\x{002c}]+(W|E)?\s*(\d*[.])?\d+(\x{00b0}\s*)?((\d*[.])?\d+((\x{0022})|((\x{0027}\s*)?)?((\d*[.])?\d+(\x{0022})?)?))?$"
test_str = ("n 1 e 0\n"
"n 1.1 e 0\n"
"n49.54.15.21 e1\n"
"n49.54.15.21° e1\n"
"n49.54.15.21' e1\n"
"n49.54.15.21\" e1\n"
"n49.54' 15.24\" e1\n"
"n49.54' 15.24.541\" e1\n"
"n49.54.15.21' 5456.4646\" e1\n"
"n 1° e 0\n"
"n 1.1° e 0\n"
"n 1.1.1° e 0\n"
"n 1°1 e 0\n"
"n 1.1°1 e 0\n"
"n 1°1' e 0\n"
"n 1.1°1' e 0\n"
"n 1.1°1.1 e 0\n"
"n 1.1°1.1' e 0\n"
"n 1°1.1.1 e 0\n"
"n 1.1°1.1.1 e 0\n"
"n 1°1.1.1' e 0\n"
"n 1.1°1.1.1' e 0\n"
"n 1.1°12.12.12 e 0\n"
"n 1.1°12.12.12' e 0\n"
"n 1°1\" e 0\n"
"n 1.1°1\" e 0\n"
"n 1°1.12.21\" e 0\n"
"n 11.11°12.212.21\" e 0\n"
"n 11.11°11.1111'12212.21\" e 0\n"
"n 11.11°11.11.11'12212.21\" e 0\n"
"n 11.11°11.1111'12.212.21\" e 0\n"
"N 0° 00' 000.000\" E 0° 00' 000\"\n"
"N0°00'000 E0°00'\n"
"n 0° 00 , w 0° 00.000\n"
"S 0° 0\" ,E 0° 0.00\"\n"
"s 0.00°, w0\n"
"N 49°121.47.247\",W16°5496.2944466.54\"\n"
"N 49°12.41.47247\",W16°54.96'4.2946654\"")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.