// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(N|S)?\s*(\d*[.])?\d+(\x{00b0}\s*)?((\d*[.])?\d+((\x{0022})|((\x{0027}\s*)?)?((\d*[.])?\d+?(\x{0022})?)?))?[\s\x{002c}]+(W|E)?\s*(\d*[.])?\d+(\x{00b0}\s*)?((\d*[.])?\d+((\x{0022})|((\x{0027}\s*)?)?((\d*[.])?\d+(\x{0022})?)?))?$").unwrap();
let string = "n 1 e 0
n 1.1 e 0
n49.54.15.21 e1
n49.54.15.21° e1
n49.54.15.21' e1
n49.54.15.21\" e1
n49.54' 15.24\" e1
n49.54' 15.24.541\" e1
n49.54.15.21' 5456.4646\" e1
n 1° e 0
n 1.1° e 0
n 1.1.1° e 0
n 1°1 e 0
n 1.1°1 e 0
n 1°1' e 0
n 1.1°1' e 0
n 1.1°1.1 e 0
n 1.1°1.1' e 0
n 1°1.1.1 e 0
n 1.1°1.1.1 e 0
n 1°1.1.1' e 0
n 1.1°1.1.1' e 0
n 1.1°12.12.12 e 0
n 1.1°12.12.12' e 0
n 1°1\" e 0
n 1.1°1\" e 0
n 1°1.12.21\" e 0
n 11.11°12.212.21\" e 0
n 11.11°11.1111'12212.21\" e 0
n 11.11°11.11.11'12212.21\" e 0
n 11.11°11.1111'12.212.21\" e 0
N 0° 00' 000.000\" E 0° 00' 000\"
N0°00'000 E0°00'
n 0° 00 , w 0° 00.000
S 0° 0\" ,E 0° 0.00\"
s 0.00°, w0
N 49°121.47.247\",W16°5496.2944466.54\"
N 49°12.41.47247\",W16°54.96'4.2946654\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}