package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0[1-9]|[12]\d|30)-(0[1-9]|1[0-2])-[0-9]{2}\s(0\d|1[1-2])\.([0-5]\d){1,2}(A|P)\s\&`)
var str = `17-08-15 12.04A &AD4 USFR EN 00*
17-08-15 13.04A &AD4 USFR EN 00*`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}