import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0[1-9]|[12]\\d|30)-(0[1-9]|1[0-2])-[0-9]{2}\\s(0\\d|1[1-2])\\.([0-5]\\d){1,2}(A|P)\\s\\&";
final String string = "17-08-15 12.04A &AD4 USFR EN 00*\n\n"
+ "17-08-15 13.04A &AD4 USFR EN 00*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}