const regex = /(0[1-9]|[12]\d|30)-(0[1-9]|1[0-2])-[0-9]{2}\s(0\d|1[1-2])\.([0-5]\d){1,2}(A|P)\s\&/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0[1-9]|[12]\\d|30)-(0[1-9]|1[0-2])-[0-9]{2}\\s(0\\d|1[1-2])\\.([0-5]\\d){1,2}(A|P)\\s\\&', '')
const str = `17-08-15 12.04A &AD4 USFR EN 00*
17-08-15 13.04A &AD4 USFR EN 00*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}