using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\s*(?P<key>\w+)+\s*]\s*(?P<value>[^[]*\s*)";
string input = @"[aaa ] some text here [bbbb3 ] some other text here [cc ] more text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}